Interlogix Product Notice

A vulnerability has been discovered in certain TruVision video recorders and encoders that can potentially allow unauthorized outside access to, and control of, the recorder/encoder.

Interlogix has updated firmware available for all TruVision video recorders and affected encoders that addresses this potential vulnerability. Based on the nature of the reported exploit, TruVision recorders or encoders either directly connected to the internet or hosted on an unsecured local network represent the highest risk.

Interlogix strongly recommends an immediate firmware update for all recorders/encoders in the high risk category – those that are either directly connected to the Internet or hosted on an unsecured local network. Interlogix also strongly recommends that all other TruVision recorders/encoders subject to this vulnerability be upgraded to this new firmware as soon as practical, but no later than your next scheduled service visit.

Click here to read the complete Interlogix Recorder Product Notice